Message
ClientInputError - Unable to find any data to create batch.
Cause
This error occurs when you try to perform an operation on the Salesforce Bulk API but have to pass in any data. Sending in empty records when using the Salesforce Bulk V2 Destination step will trigger this error for example.
Resolution
Update the logic of your flow so that Salesforce Bulk V2 Destination steps are not triggered with empty records.
Error Detail
{
"message": {
"name": "ClientInputError",
"errorCode": "ClientInputError"
},
"error": {
"name": "ClientInputError",
"errorCode": "ClientInputError",
"fields": null,
"message": "Unable to find any data to create batch"
},
"statusCode": 500,
"errorMessage": "Unable to find any data to create batch"
}