Message
Error with oAuth refresh token request: ECONNRESET
Cause
This error is triggered when there is an error trying to reach Salesforce servers in order to renew the OAuth refresh token. It could be caused by connectivity issues as the `ECONNRESET` error means the connection to Salesforce was unexpectedly closed or reset before the request could complete.
Resolution
This error is often a transient one and re-running the flow should resolve it. In case the flow reruns also result in an error, make sure you are still within Salesforce's limits on API calls. If the error persists, contact Synatic support.
Error Detail
```json
{
"message": "Unable to lookup",
"statusCode": 500,
"errorMessage": "Error with oAuth refresh token request",
"error": {
"message": "Error with oAuth refresh token request",
"statusCode": 500,
"error": {
"errno": -104,
"code": "ECONNRESET",
"syscall": "write"
},
"errorMessage": "https://login.salesforce.com/services/oauth2/token?client_id=%5BREDACTED%5D&client_secret=%5BREDACTED%5D&refresh_token=%5BREDACTED%5D&grant_type=refresh_token",
"body": null
}
}
```