Message
Upsert sObject HTTP Error
Cause
This is an error with upserting data into Salesforce. This can occur for several different reasons, including:
Incorrect data type - The data type of the field being updated or inserted does not support the value being used. For example, if a date field is sent as a string, the call will fail.
Incorrect data format - The data of the field being updated is incorrectly formatted. For example, if an email is being updated and the email string sent is not a valid email address.
Duplicate external ID - Salesforce will not allow multiple records with the same external ID to be processed in the same batch.
Conflicting Top Level Domain (TLD) - Some TLDs can conflict with certain file format extensions. For example, using an email address as the external ID may return a 404 not found error.
Resolution
The specific resolution for this type of error depends on the nature of the issue that caused it. Often there will be inner error details that give more information on any bad data types and/or data formatting issues which can be used to guide you towards solving data input issues.
Inspect objects before they are sent to look for any possible data issues present in them. The additional error details may provide the object IDs of failing objects.
Error Detail
{
"message": "Upsert sObject HTTP Error",
"statusCode": 400,
"url": "https://companyname.my.salesforce.com/services/data/v51.0/sobjects/Account/Unique_Id_Synatic__c/Johnwick******.ukGarrettLL18 3RHTue, 09 Jan 1979 00:00:00 GMT",
"retries": null,
"error": {
"message": "Email: invalid email address: Johnwick*****.uk",
"errorCode": "INVALID_EMAIL_ADDRESS",
"fields": [
"PersonEmail"
]
}
}