Message
Error connecting to SQL server.
Cause
This error can be caused by a few issues:
Network issues: There might be connectivity issues preventing a connection to SQL Server.
SQL Server might be unavailable.
Authentication problems due to incorrect credentials.
Invalid configuration of IP address, port or DNS settings.
Resolution
Resolving this issue will depend on the exact cause of the problem but there are a few steps you can take to resolve this. Make sure the server config (IP address, connection string, port and credentials) are correct. If the config is confirmed to be correct, test that the SQL server is reachable and is not experiencing any connectivity or network issues. If none of these steps helps resolve the error, please contact the Synatic Support Team.
Error Detail
{
"error": {
"message": "Failed to connect to XXX.XXX.XXX.XXX:XXX in 15000ms",
"code": "ETIMEOUT"
},
"errorMessage": "Failed to connect to 63.XX.3.1XX:XXXX in 15000ms",
"statusCode": 500,
"stepType": "Destination",
"stepName": "RelayAsync",
"stepld": "1XXXXXXXXXXXXXX",
"mapStepType": "Step",
"messageld": "6789XXXXXXc",
"threadld": 1
}