Message
Socket 'secureConnect' timed out
Cause
When Synatic cannot establish a secure HTTPS connection to a 3rd-party API via a step in a flow. There a many possibilities as to why this would occur, these might include:
A transient error due to network instability between a 3rd-party API and Synatic.
A failed TSL certificate validation from a 3rd-party API.
A 3rd-party API is experiencing some sort of service outage.
In most cases, this is caused by transient network instability.
Resolution
As Synatic does not have direct control over the 3rd-party APIs, we integrate them into the network between us and them. There are not a lot of factors we can directly control or influence. Please try the following steps in order to resolve your problem
Identify the 3rd-party APIs used within the affected flow.
Check the availability of the 3rd-party APIs by using a tool such as Postman. If the request fails in Postman reach out the the 3rd-party API provider for assistance.
Re-run the affected flow in the case of the 3rd-party API being available.
If the error persists, reach out to Synatic support.
Error Detail
{
"error": {
"errorResponse": {
"connectionGeneration": 1
},
"connectionGeneration": 1,
"writeErrors": [],
"result": {
"insertedCount": 0,
"matchedCount": 0,
"modifiedCount": 0,
"deletedCount": 0,
"upsertedCount": 0,
"upsertedIds": {},
"insertedIds": {}
}
},
"message": "Socket 'secureConnect' timed out after 90054ms (connectTimeoutMS: 30000)",
"errorMessage": "Socket 'secureConnect' timed out after 90054ms (connectTimeoutMS: 30000)",
"invalid": null,
"stepType": "Source",
"stepName": "RelayAsync",
"title": null,
"statusCode": 500,
"orgId": null,
"stepId": "06d83f0f-f80e-4244-889f-b11bccdb44dd",
"mapStepId": null,
"mapStepPath": null,
"mapStepType": "Step",
"module": null,
"commandProcessingError": null
}